$re = '/(\[\[outlook:)([0-9A-Z]*)(\]\[)(.*)(\]\])/';
$str = '[[outlook:000000003730C053465F314590D066368CF3097B0700AAF83E03F96EDC42918E044642DEDDB3000013E2000E0000AAF83E03F96EDC42918E044642DEDDB3000013E2EFD30000][MESSAGE: RE: Subject of the Message (Sendername Senderfirstname) 2014-08-05 19:48]]
[[http:000000003730C053465F314590D066368CF3097B0700AAF83E03F96EDC42918E044642DEDDB3000013E2000E0000AAF83E03F96EDC42918E044642DEDDB3000013E2EFD30000][MESSAGE: RE: Subject of the Message (Sendername Senderfirstname) 2014-08-05 19:48]]';
$subst = "[[path\\outlook\\\2\.msg\3\4\5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;