re = /^1?\s?\(\d{3}\)\s?\d{3}\s?-?\d{4}$|^(?:1\s)?\d{3}(\s|-)?\d{3}\1\d{4}$/
str = '1 555 555 6565'
# Print the match result
str.match(re) do |match|
puts match.to_s
end