using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1?\s?\(\d{3}\)\s?\d{3}\s?-?\d{4}$|^(?:1\s)?\d{3}(\s|-)?\d{3}\1\d{4}$";
string input = @"1 555 555 6565";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}