import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1?\\s?\\(\\d{3}\\)\\s?\\d{3}\\s?-?\\d{4}$|^(?:1\\s)?\\d{3}(\\s|-)?\\d{3}\\1\\d{4}$";
final String string = "1 555 555 6565";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}