re = /for( )+(([$,_,?,!,*]*[A-Z]*+[a-z]*)+)[ ]+in( )+([\D]+([(][\D]*[)])?):/m
str = 'for *Col in lol:
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end