using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"for( )+(([$,_,?,!,*]*[A-Z]*+[a-z]*)+)[ ]+in( )+([\D]+([(][\D]*[)])?):";
string input = @"for *Col in lol:
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}