$re = '/for( )+(([$,_,?,!,*]*[A-Z]*+[a-z]*)+)[ ]+in( )+([\D]+([(][\D]*[)])?):/m';
$str = 'for *Col in lol:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);