re = /(?:([0-2]?[1-9]):([0-5][0-9])(?: ?([ap]m?))?|([0-2]?[1-9])(?: ?([ap]m?)))/i
str = '5am
5 pm
5:00am
4:20pm
2:20 AM
12:00 pm
12:00am
8:00
12:00
8pm
7:pm
5:00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end