import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:([0-2]?[1-9]):([0-5][0-9])(?: ?([ap]m?))?|([0-2]?[1-9])(?: ?([ap]m?)))";
final String string = "5am\n"
+ "5 pm\n"
+ "5:00am\n"
+ "4:20pm\n"
+ "2:20 AM\n"
+ "12:00 pm\n"
+ "12:00am\n"
+ "8:00\n"
+ "12:00\n"
+ "8pm\n"
+ "7:pm\n"
+ "5:00\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}