#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:([0-2]?[1-9]):([0-5][0-9])(?: ?([ap]m?))?|([0-2]?[1-9])(?: ?([ap]m?)))"
Local $sString = "5am" & @CRLF & _
"5 pm" & @CRLF & _
"5:00am" & @CRLF & _
"4:20pm" & @CRLF & _
"2:20 AM" & @CRLF & _
"12:00 pm" & @CRLF & _
"12:00am" & @CRLF & _
"8:00" & @CRLF & _
"12:00" & @CRLF & _
"8pm" & @CRLF & _
"7:pm" & @CRLF & _
"5:00" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")