re = /(([^,]*,){2})/m
str = 'nsi_file_status,host=pi-test.rusklimat.ru Message_000_113_CountRecord=5,endTime=1695132572,iterator=1,longtime=30,processFail=0,processFailDomainException=0,processFailException=0,processFailInvalidArgumentException=0,processSuccess=5,processTotal=5,startTime=1695132542,timeStamp=1695132542 1695132700000000000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end