use strict;
my $str = 'nsi_file_status,host=pi-test.rusklimat.ru Message_000_113_CountRecord=5,endTime=1695132572,iterator=1,longtime=30,processFail=0,processFailDomainException=0,processFailException=0,processFailInvalidArgumentException=0,processSuccess=5,processTotal=5,startTime=1695132542,timeStamp=1695132542 1695132700000000000
';
my $regex = qr/(([^,]*,){2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}