const regex = /(([^,]*,){2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([^,]*,){2})', 'gm')
const str = `nsi_file_status,host=pi-test.rusklimat.ru Message_000_113_CountRecord=5,endTime=1695132572,iterator=1,longtime=30,processFail=0,processFailDomainException=0,processFailException=0,processFailInvalidArgumentException=0,processSuccess=5,processTotal=5,startTime=1695132542,timeStamp=1695132542 1695132700000000000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}