use strict;
my $str = '+1 (555) 555-5555
+1 (555) 555-55555
+90 532 581 98 18
+90 532 581 98 186
+358 44 944 30 13
+358 44 944 30 133';
my $regex = qr/(^\+\d\s\(\d{3}\)\s\d{3}\-\d{4}$|^\+\d{1,3}\s\d{2,3}\s\d{2,3}\s\d{2,3}\s\d{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}