package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\+\d\s\(\d{3}\)\s\d{3}\-\d{4}$|^\+\d{1,3}\s\d{2,3}\s\d{2,3}\s\d{2,3}\s\d{2})`)
var str = `+1 (555) 555-5555
+1 (555) 555-55555
+90 532 581 98 18
+90 532 581 98 186
+358 44 944 30 13
+358 44 944 30 133`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}