import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\+\\d\\s\\(\\d{3}\\)\\s\\d{3}\\-\\d{4}$|^\\+\\d{1,3}\\s\\d{2,3}\\s\\d{2,3}\\s\\d{2,3}\\s\\d{2})";
final String string = "+1 (555) 555-5555\n"
+ "+1 (555) 555-55555\n"
+ "+90 532 581 98 18\n"
+ "+90 532 581 98 186\n"
+ "+358 44 944 30 13\n"
+ "+358 44 944 30 133";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}