const regex = /(?:\(\d{3}\)*\s\d{3}-\d{4})|(?:\d{3}(?:-|\s*)\d{3}-\d{4})|(?:\d{10})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\(\\d{3}\\)*\\s\\d{3}-\\d{4})|(?:\\d{3}(?:-|\\s*)\\d{3}-\\d{4})|(?:\\d{10})', 'gm')
const str = `801-555-6432
(801) 556-9023
702 556-9023
7025569023
(801)556-9023`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}