package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\(\d{3}\)*\s\d{3}-\d{4})|(?:\d{3}(?:-|\s*)\d{3}-\d{4})|(?:\d{10})`)
var str = `801-555-6432
(801) 556-9023
702 556-9023
7025569023
(801)556-9023`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}