import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\(\\d{3}\\)*\\s\\d{3}-\\d{4})|(?:\\d{3}(?:-|\\s*)\\d{3}-\\d{4})|(?:\\d{10})";
final String string = "801-555-6432\n"
+ "(801) 556-9023\n"
+ "702 556-9023\n"
+ "7025569023\n"
+ "(801)556-9023";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}