re = /batiment restructur[eé]/m
str = 'plateaux entièrement rénovés XXXXXX immeuble de style industriel restructuré
surface livrée rénovée et climatisée dans un magnifique immeuble haussmannien restructuré
batiment restructuré XXXXXX plateau livré entièrement rénové et décloisonné
parking exterieur restructuré XXXXX bureau rénové
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end