$re = '/batiment restructur[eé]/m';
$str = 'plateaux entièrement rénovés XXXXXX immeuble de style industriel restructuré
surface livrée rénovée et climatisée dans un magnifique immeuble haussmannien restructuré
batiment restructuré XXXXXX plateau livré entièrement rénové et décloisonné
parking exterieur restructuré XXXXX bureau rénové
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);