const regex = new RegExp('batiment restructur[eé]', 'gm')
const str = `plateaux entièrement rénovés XXXXXX immeuble de style industriel restructuré
surface livrée rénovée et climatisée dans un magnifique immeuble haussmannien restructuré
batiment restructuré XXXXXX plateau livré entièrement rénové et décloisonné
parking exterieur restructuré XXXXX bureau rénové
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}