re = /^[a-zA-Z\_-]+/m
str = 'keithkeekw@icloud.com
keithkeekw@gmail.com
kwkee@msafocus.com.my'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end