$re = '/^[a-zA-Z\_-]+/m';
$str = 'keithkeekw@icloud.com
keithkeekw@gmail.com
kwkee@msafocus.com.my';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);