package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z\_-]+`)
var str = `keithkeekw@icloud.com
keithkeekw@gmail.com
kwkee@msafocus.com.my`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}