const regex = /^(?=.*\d)(?=.*[^\w\s]).{8,}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\d)(?=.*[^\\w\\s]).{8,}$', 'mg')
const str = `Valid passwords:
xkM65!asd
a8jjxa39!af
!r3g3x101!
Tr0ub4dor&3
Invalid passwords:
correcthorsebatterystaple
password
jh81?
starwarsrulez1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}