#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\d)(?=.*[^\w\s]).{8,}$"
Local $sString = "Valid passwords:" & @CRLF & _
"xkM65!asd" & @CRLF & _
"a8jjxa39!af" & @CRLF & _
"!r3g3x101!" & @CRLF & _
"Tr0ub4dor&3" & @CRLF & _
"" & @CRLF & _
"Invalid passwords:" & @CRLF & _
"correcthorsebatterystaple" & @CRLF & _
"password" & @CRLF & _
"jh81?" & @CRLF & _
"starwarsrulez1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")