import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\d)(?=.*[^\\w\\s]).{8,}$";
final String string = "Valid passwords:\n"
+ "xkM65!asd\n"
+ "a8jjxa39!af\n"
+ "!r3g3x101!\n"
+ "Tr0ub4dor&3\n\n"
+ "Invalid passwords:\n"
+ "correcthorsebatterystaple\n"
+ "password\n"
+ "jh81?\n"
+ "starwarsrulez1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}