import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "from:\\s*\"+\\s*bob*+\\s*\"\\s*,\\s*to:\\s*\"\\s*[a-zA-Z]*\\s*\"\\s*,\\s*content:\\s*\"\\s*[a-zA-Z]*\\s*\"\\s*";
final String string = "from: \"bob\", to: \"Receiver\", content: \"Payload\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}