package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)from:\s*"+\s*bob*+\s*"\s*,\s*to:\s*"\s*[a-zA-Z]*\s*"\s*,\s*content:\s*"\s*[a-zA-Z]*\s*"\s*`)
var str = `from: "bob", to: "Receiver", content: "Payload"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}