using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"from:\s*""+\s*bob*+\s*""\s*,\s*to:\s*""\s*[a-zA-Z]*\s*""\s*,\s*content:\s*""\s*[a-zA-Z]*\s*""\s*";
string input = @"from: ""bob"", to: ""Receiver"", content: ""Payload""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}