import Foundation
let pattern = #"(?'comando'\w+)(?'valor'\(.*?\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
search(objeto(atributo.subatributo)).equals(1).and(search(objeto2(atributo2)).gte(1))
group(objeto(atributo)).equals(1).orderby(atributo.field)
objeto(atributo).equals(1)
search(objeto(attr)).and(seach(objeto(attr2)).and(search(objeto(attr3)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)