re = /(?'comando'\w+)(?'valor'\(.*?\))/m
str = '
search(objeto(atributo.subatributo)).equals(1).and(search(objeto2(atributo2)).gte(1))
group(objeto(atributo)).equals(1).orderby(atributo.field)
objeto(atributo).equals(1)
search(objeto(attr)).and(seach(objeto(attr2)).and(search(objeto(attr3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end