import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'comando'\\w+)(?'valor'\\(.*?\\))";
final String string = "\n"
+ "search(objeto(atributo.subatributo)).equals(1).and(search(objeto2(atributo2)).gte(1))\n\n"
+ "group(objeto(atributo)).equals(1).orderby(atributo.field)\n"
+ "objeto(atributo).equals(1)\n\n"
+ "search(objeto(attr)).and(seach(objeto(attr2)).and(search(objeto(attr3)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}