use strict;
my $str = '234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454.238.890,00';
my $regex = qr/^(((\d+)(\.\d{3})*(,\d{2}))|(\d*))$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}