const regex = /^(((\d+)(\.\d{3})*(,\d{2}))|(\d*))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((\\d+)(\\.\\d{3})*(,\\d{2}))|(\\d*))$', '')
const str = `234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454.238.890,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}