import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\d+)(\\.\\d{3})*(,\\d{2}))|(\\d*))$";
final String string = "234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454.238.890,00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}