// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{2})(\d{2})(\d{2})").unwrap();
let string = "140923";
let substitution = "$3/$2/$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}