const regex = /(\d{2})(\d{2})(\d{2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2})(\\d{2})(\\d{2})', '')
const str = `140923`;
const subst = `$3/$2/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);