use strict;
my $str = '140923';
my $regex = qr/(\d{2})(\d{2})(\d{2})/p;
my $subst = '$3/$2/$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";