const regex = /\d+[.,]?(\d+\s*k?|x{2,3})(?=\s*(original|actual|highway)?\s*miles)|(?<=mile(s|agex?):?\s*(is|~)?\s*)\d+[.,]?(\d+(\s*k)?|x{2,3})|(\d+(\s*K)|x{2,3})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+[.,]?(\\d+\\s*k?|x{2,3})(?=\\s*(original|actual|highway)?\\s*miles)|(?<=mile(s|agex?):?\\s*(is|~)?\\s*)\\d+[.,]?(\\d+(\\s*k)?|x{2,3})|(\\d+(\\s*K)|x{2,3})', 'i')
const str = `123456789012`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}