import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+[.,]?(\\d+\\s*k?|x{2,3})(?=\\s*(original|actual|highway)?\\s*miles)|(?<=mile(s|agex?):?\\s*(is|~)?\\s*)\\d+[.,]?(\\d+(\\s*k)?|x{2,3})|(\\d+(\\s*K)|x{2,3})";
final String string = "123456789012";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}