using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+[.,]?(\d+\s*k?|x{2,3})(?=\s*(original|actual|highway)?\s*miles)|(?<=mile(s|agex?):?\s*(is|~)?\s*)\d+[.,]?(\d+(\s*k)?|x{2,3})|(\d+(\s*K)|x{2,3})";
string input = @"123456789012";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}