$re = '/(?:[NV]|GH)?([0-9-]+(?:[SF]|[A-Z])?)+(?:[A-Za-z]{1,3}[0-9]+|DV|D)?/';
$str = '10y4
4035sf
v10
v10y4
gh303
1526yuj23
10dv
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);