import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[NV]|GH)?([0-9-]+(?:[SF]|[A-Z])?)+(?:[A-Za-z]{1,3}[0-9]+|DV|D)?";
final String string = "10y4\n"
+ "4035sf\n"
+ "v10\n"
+ "v10y4\n"
+ "gh303\n"
+ "1526yuj23\n"
+ "10dv\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}