#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[NV]|GH)?([0-9-]+(?:[SF]|[A-Z])?)+(?:[A-Za-z]{1,3}[0-9]+|DV|D)?"
Local $sString = "10y4" & @CRLF & _
"4035sf" & @CRLF & _
"v10" & @CRLF & _
"v10y4" & @CRLF & _
"gh303" & @CRLF & _
"1526yuj23" & @CRLF & _
"10dv" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")