re = /^(?P<demo1>[A-Za-z]+)(?:(?:,\s*)|(?:\s+))(?P<demo2>[A-Za-z]+)/m
str = 'abc, def'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end