using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<demo1>[A-Za-z]+)(?:(?:,\s*)|(?:\s+))(?P<demo2>[A-Za-z]+)";
string input = @"abc, def";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}