package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<demo1>[A-Za-z]+)(?:(?:,\s*)|(?:\s+))(?P<demo2>[A-Za-z]+)`)
var str = `abc, def`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}