use strict;
my $str = '29-02-2016 00:00:46.676 [qtp1746080167-2900285] [ERROR] DefaultDao - Error executing query.
java.lang.Exception: Update count not satisfied.
at com.til.etwealth.etmoney.db.entity.query.sql.';
my $regex = qr/(?:(?:0[1-9])|(?:[12][0-9])|(?:3[01])|[1-9])/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}